Search found 25 matches

by lbw
07 Dec 2020, 03:40
Forum: Radius
Topic: accel-ppp stops processing packets when RADIUS is unavailable
Replies: 2
Views: 928

Re: accel-ppp stops processing packets when RADIUS is unavailable

I'm not sure that I understand why increasing that make any discernible difference? Looking at the code, all that would do is merely delay the same problem from happening maybe 1 second later? The issue is if the RADIUS server is unavailable for let's say an hour, the entire accel-ppp stack stops wo...
by lbw
06 Dec 2020, 07:59
Forum: Radius
Topic: accel-ppp stops processing packets when RADIUS is unavailable
Replies: 2
Views: 928

accel-ppp stops processing packets when RADIUS is unavailable

Hi I've noticed accel-ppp stops processing packets for PPPoE and L2TP type services when RADIUS services become unresponsive or slow. My guess is that the request queue is overwhelmed with RADIUS requests and it stops or slows processing others to almost a halt as all threads become busy/overwhelmed...
by lbw
22 Aug 2020, 04:59
Forum: Radius
Topic: Plugins?
Replies: 0
Views: 790

Plugins?

I noticed in the RADIUS code there's infrastructure for a rad_plugin_t and plugins. These seem to be able modify requests. However, there's no where to specify them or load them in the configuration. Am I misunderstanding the purpose of this code or is it mostly there but just missing some surroundi...
by lbw
13 Aug 2020, 12:56
Forum: PPPoE
Topic: So I had put accel-ppp live with heavy load
Replies: 45
Views: 14340

Re: So I had put accel-ppp live with heavy load

I'm using Debian 9 but your issue sounds like it is more network related. Check your NIC buffers and your switch port buffers and statistics.
by lbw
18 Jul 2020, 12:11
Forum: PPPoE
Topic: So I had put accel-ppp live with heavy load
Replies: 45
Views: 14340

Re: So I had put accel-ppp live with heavy load

I'm running accel-ppp on multiple servers each doing 3Gbps load with mixture of PPPoE and L2TP without issue (touch wood) using 10-Gigabit X540-AT2, 4.9.0-11-amd64 and 8 x E3-1270 and accel-ppp has been running for about 150 days with ~1000 sessions. Can you scale horizontally?
by lbw
18 Jul 2020, 11:56
Forum: L2TP
Topic: accel-ppp as a L2TP LAC?
Replies: 2
Views: 2581

Re: accel-ppp as a L2TP LAC?

No solution. I was hoping @dimka88 might shed some light if this is possible with the current code or if I need to try and patch it so I don't spend a hours trying to work it out.
by lbw
29 May 2020, 12:05
Forum: L2TP
Topic: L2TP internal queue is never drained resulting in no new sessions allowed
Replies: 1
Views: 543

Re: L2TP internal queue is never drained resulting in no new sessions allowed

Looking further at this, because it keeps happening, I've gathered the following logs (with some extra debugging entires added by me): [2020-05-27 10:25:01]: info: l2tp tunnel 20306-17769 (1.2.3.233:1701): retransmission #1 [2020-05-27 10:25:01]: info: l2tp tunnel 20306-17769 (1.2.3.233:1701): retra...
by lbw
12 Mar 2020, 10:30
Forum: PPPoE
Topic: Adding PPPoE interface with QinQ with accel-cmd misses inside tag
Replies: 4
Views: 533

Re: Adding PPPoE interface with QinQ with accel-cmd misses inside tag

That does not solve the problem and in fact, makes it worse in the following use case: 1. You cannot run say: accel-cmd# pppoe interface add eth3.2702.1200 Without the interface eth3.2702.1200 being up. Usually, the interface associated with the c-tag will be auto-created by accel-ppp. Therefore, I ...
by lbw
05 Mar 2020, 07:41
Forum: Feature requests
Topic: Shaper - Factor default speed received
Replies: 1
Views: 435

Re: Shaper - Factor default speed received

Do this in your RADIUS server. It's not a job for a BRAS.
by lbw
23 Feb 2020, 03:01
Forum: Bugs
Topic: Problem with Vlan-mon and Intel X710/X722
Replies: 7
Views: 726

Re: Problem with Vlan-mon and Intel X710/X722

It might be worth switching to a X540 or X520. They are relatively cheap and see if that solves your problem?