My ipoe configuration!!! Still can not work!!!

IPoE related questions
Post Reply
ztaozhang
Posts: 10
Joined: 24 Jan 2018, 07:31

My ipoe configuration!!! Still can not work!!!

Post by ztaozhang » 26 Jan 2018, 04:06

Code: Select all

#ABillS
[modules]
log_file
ipoe
ippool
auth_pap
auth_mschap_v2
#auth_pap
auth_chap_md5
auth_mschap_v1
chap-secrets
sigchld

[core]
log-error=/var/log/accel-ppp/core.log
thread-count=1

#[common]
#single-session=replace
#sid-case=upper
#sid-source=seq

[auth]
#any-login=0
noauth=1


[ipoe]
verbose=100
#username=ifname
username=lua:username
lua-file=/etc/accel-ppp.lua
password=username
#password=password
lease-time=300
max-lease-time=300
#attr-dhcp-client-ip=Framed-IP-Address
gw-ip-address=192.168.100.1/24
proxy-arp=1
shared=0
ifcfg=1
mode=L2
#relay=192.168.100.1
start=up
start=dhcpv4
ip-pool=pool1
interface=enp4s0
#agent-remote-id=accel-ppp
#attr-dhcp-opt82=DHCP-Option82

[ip-pool]
#gw-ip-address=192.168.0.1/24
#attr=Framed-Pool
192.168.100.80-254,name=pool1
10.10.10.1-200,name=pool2

[client-ip-range]
#0.0.0.0/0
#192.168.10.0/24
disable

[dns]
dns1=8.8.8.8

[log]
log-file=/var/log/accel-ppp/accel-ppp.log
log-emerg=/var/log/accel-ppp/emerg.log
log-fail-file=/var/log/accel-ppp/auth-fail.log
copy=1
color=1
#per-user-dir=per_user
#per-session-dir=per_session
#per-session=1
level=100

[chap-secrets]
#gw-ip-address=192.168.100.1
chap-secrets=/etc/ppp/chap-secrets
encrypted=0
#username-hash=md5

[cli]
verbose=100
telnet=127.0.0.1:2000
tcp=127.0.0.1:2001
password=radsecret

[snmp]
master=0
agent-name=accel-ppp

[connlimit]
limit=10/min
burst=3
timeout=60

Code: Select all

accel-ppp.lua

function username(pkt)
return pkt:hdr('chaddr')
end    

Code: Select all

enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.10.100  netmask 255.255.255.0  broadcast 192.168.10.255
        inet6 fe80::225:90ff:fe6c:3f94  prefixlen 64  scopeid 0x20<link>
        ether 00:25:90:6c:3f:94  txqueuelen 1000  (Ethernet)
        RX packets 30177  bytes 2096161 (1.9 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 69775  bytes 98736364 (94.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16  memory 0xfb3e0000-fb400000  

enp4s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::225:90ff:fe6c:3f95  prefixlen 64  scopeid 0x20<link>
        ether 00:25:90:6c:3f:95  txqueuelen 1000  (Ethernet)
        RX packets 304  bytes 122512 (119.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 60  bytes 4880 (4.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17  memory 0xfb4e0000-fb500000  

Code: Select all

The error occurred, the client can not connect

[2018-01-25 12:45:00]:  info: enp4s0: recv [DHCPv4 Discover xid=f077811 chaddr=6c:ef:c6:05:47:3c <Message-Type Discover> <Client-ID 016cefc605473c> <Max-Message-Size 1500> <Vendor-Class 00001f31013130323731383736313630313030383515c4199cf339758b85ebb305d1ac15cc1cda41677763557b7b030c5d765fe774> <Host-Name 000004000008892016346CEFC605473C> <Request-List Subnet,Route,Router,DNS,Domain-Name,Broadcast,Lease-Time,T1,T2>]
[2018-01-25 12:45:00]:  [b]info: enp4s0: (null): authentication succeeded[/b]
[2018-01-25 12:45:00]: [b]error: enp4s0: no free IPv4 address[/b]
[2018-01-25 12:45:00]: debug: enp4s0: terminate
[2018-01-25 12:45:00]:  info: enp4s0: ipoe: session finished

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest