проблема с интерфейсами IPOE

IPoE related questions
Nesta
Posts: 2
Joined: 09 Oct 2017, 07:20

Re: проблема с интерфейсами IPOE

Post by Nesta » 09 Oct 2017, 09:13

Вообще это глобальная проблема или частный случай? Есть ли те кто юзает IPoE свыше 1к пользователей онлайн?

dimka88
Posts: 431
Joined: 13 Oct 2014, 05:51
Contact:

Re: проблема с интерфейсами IPOE

Post by dimka88 » 09 Oct 2017, 09:40

Да по наполнению темы и количеству просмотров можно понять, что она есть.
Проблема в том, что на стенде выловить сложно, было как то 3 попытки уже. Тут еще есть нюанс, процент использующих shared=1 меньше чем vlan на пользователя.
Дмитрий говорил попробует дебагером отследить, а вам предлагаю все же не опускать руки и попробовать детально зажурналировать функцию ipoe_session_finished и прочие участвующие в завершении сессий.
Ну и попробуйте все же сделать unit-cahche=-1 если возможно.

c3pO
Posts: 6
Joined: 07 Oct 2017, 18:54

Re: проблема с интерфейсами IPOE

Post by c3pO » 09 Oct 2017, 10:08

dimka88 wrote:
09 Oct 2017, 09:40
Да по наполнению темы и количеству просмотров можно понять, что она есть.
Проблема в том, что на стенде выловить сложно, было как то 3 попытки уже. Тут еще есть нюанс, процент использующих shared=1 меньше чем vlan на пользователя.
Дмитрий говорил попробует дебагером отследить, а вам предлагаю все же не опускать руки и попробовать детально зажурналировать функцию ipoe_session_finished и прочие участвующие в завершении сессий.
Ну и попробуйте все же сделать unit-cahche=-1 если возможно.
Рад видеть что тема оживилась, руки опускать не собираемся, @dimka88 подскажи как включить дополнительный дебаг?
unit-cahche=-1 затестируем, отпишусь по результатам.

dimka88
Posts: 431
Joined: 13 Oct 2014, 05:51
Contact:

Re: проблема с интерфейсами IPOE

Post by dimka88 » 09 Oct 2017, 10:18

Нужно лезть в код .../accel-pppd/ctrl/ipoe/ipoe.c и пытаться понять как работает функция static void ipoe_session_finished(struct ap_session *s).
В данной функции дописывать дополнительно строки log_ppp_info1("Что конкретно выводить данным событием\n") и пересобирать accel-ppp.
Делать это не на стенде очень плачевно, так что запасайтесь терпением поднимайте тестовый тазик и добро пожаловать в сообщество =).

Для общения так же можете использовать telegram канал https://t.me/joinchat/DS6swRC3DvEWdNijTqaaeA

Dmitry
Администратор
Posts: 949
Joined: 09 Oct 2014, 10:06

Re: проблема с интерфейсами IPOE

Post by Dmitry » 09 Oct 2017, 13:42

Под спойлером кусок дебага по интерфейсу ipoe410
можно по приведённому логу сделать grep 172.19.57.185

Dmitry
Администратор
Posts: 949
Joined: 09 Oct 2014, 10:06

Re: проблема с интерфейсами IPOE

Post by Dmitry » 09 Oct 2017, 13:45

и логи желательно приводить из файла который debug-log

c3pO
Posts: 6
Joined: 07 Oct 2017, 18:54

Re: проблема с интерфейсами IPOE

Post by c3pO » 09 Oct 2017, 19:36

Доброго времени суток,

unit-cahche=-1 не прокатило, причем ошибки полезли сразу. Добавление дополнительного дебага еще в процессе.
можно по приведённому логу сделать grep 172.19.57.185
и логи желательно приводить из файла который debug-log
Это как раз был вывод log-debug и к сожалению лог уже удален из-за многочисленных рестартов.
Пришлось засунуть его под спойлер т.к. при попытке добавить в аттач одна и таже ошибка что не верное расширение файла как бы я его не менял либо убирал вообще.

Выложил debug-log за пол дня работы сервиса с его момента старта, ошибок там достаточно, если необходимы еще данные дайте пожалуйста знать:
http://195.54.42.163/accel-debug.tar.gz (28M)
http://195.54.42.163/accel-debug.log (307M)

Спасибо всем кто отозвался!

Dmitry
Администратор
Posts: 949
Joined: 09 Oct 2014, 10:06

Re: проблема с интерфейсами IPOE

Post by Dmitry » 10 Oct 2017, 08:27

ну вот смотри из твоих логов:
1-я сессия:
[2017-10-08 15:27:20.564] ipoe983: 2918e86cfb664735: create interface ipoe983 parent bond0.259
[2017-10-08 15:27:20.564] ipoe983: 2918e86cfb664735: send [RADIUS(1) Access-Request id=1 <User-Name "00:e0:4c:3a:d1:f0"> <NAS-Identifier "accel-ppp"> <NAS-IP-Address 192.168.0.1> <NAS-Port 938424> <NAS-Port-Id "ipoe983"> <NAS-Port-Type Ethernet> <Calling-Station-Id "00:e0:4c:3a:d1:f0"> <Called-Station-Id "bond0.259"> <User-Password>]
[2017-10-08 15:27:20.602] ipoe983: 2918e86cfb664735: recv [RADIUS(1) Access-Accept id=1 <Framed-IP-Address 172.19.57.185>]
2-я сессия:
[2017-10-08 15:37:32.493] ipoe410: 2918e86cfb664757: create interface ipoe410 parent bond0.262
[2017-10-08 15:37:32.493] ipoe410: 2918e86cfb664757: send [RADIUS(1) Access-Request id=1 <User-Name "c4:6e:1f:8b:6e:2f"> <NAS-Identifier "accel-ppp"> <NAS-IP-Address 192.168.0.1> <NAS-Port 938458> <NAS-Port-Id "ipoe410"> <NAS-Port-Type Ethernet> <Calling-Station-Id "c4:6e:1f:8b:6e:2f"> <Called-Station-Id "bond0.262"> <User-Password>]
[2017-10-08 15:37:32.534] ipoe410: 2918e86cfb664757: recv [RADIUS(1) Access-Accept id=1 <Framed-IP-Address 172.19.57.185>]
[2017-10-08 15:37:32.534] ipoe410: 2918e86cfb664757: c4:6e:1f:8b:6e:2f: authentication succeeded
[2017-10-08 15:37:32.534] ipoe410: 2918e86cfb664757: send [DHCPv4 Offer xid=9fea4740 yiaddr=172.19.57.185 chaddr=c4:6e:1f:8b:6e:2f <Message-Type Offer> <Server-ID 172.19.57.1> <Lease-Time 600> <T1 300> <Router 172.19.57.1> <Subnet 255.255.255.0> <DNS 8.8.8.8,8.8.4.4>]
[2017-10-08 15:37:32.543] ipoe410: 2918e86cfb664757: recv [DHCPv4 Request xid=9fea4740 chaddr=c4:6e:1f:8b:6e:2f <Message-Type Request> <Max-Message-Size 1024> <Client-ID 01c46e1f8b6e2f> <Host-Name TL-WR841N> <Vendor-Class 4d53465420352e30> <Request-IP 172.19.57.185> <Server-ID 172.19.57.1> <Request-List Subnet,Router,DNS,Domain-Name,Route,Vendor-Specific,44,46,47,Classless-Route,249>]
[2017-10-08 15:37:32.543] ipoe410: 2918e86cfb664757: ipoe: activate session
[2017-10-08 15:37:32.543] ipoe410: 2918e86cfb664757: ipoe: nl_create: error talking to kernel
[2017-10-08 15:37:32.543] ipoe410: 2918e86cfb664757: terminate
[2017-10-08 15:37:32.543] ipoe410: 2918e86cfb664757: ipoe: session finished
как и предполагалось радиус выдаёт уже занятый ип

dimka88
Posts: 431
Joined: 13 Oct 2014, 05:51
Contact:

Re: проблема с интерфейсами IPOE

Post by dimka88 » 10 Oct 2017, 08:33

Может попробовать обрабатывать эти грабли с помощью accel-ppp?
Например завершать сессию с занятым IP, и вторая модель поведения запрещать стартовать сессию с характерным выводом в журнал. Кстати, по этому поводу у accel-ppp есть наработки, check-ip но он только для ppp.

Dmitry
Администратор
Posts: 949
Joined: 09 Oct 2014, 10:06

Re: проблема с интерфейсами IPOE

Post by Dmitry » 10 Oct 2017, 08:44

так он и обрабатывает - не даёт создавать вторую сессию, иначе обе не будут работать
для ппп check-ip делает то-же самое

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest