проблема с интерфейсами IPOE

IPoE related questions
Dmitry
Администратор
Posts: 949
Joined: 09 Oct 2014, 10:06

Re: проблема с интерфейсами IPOE

Post by Dmitry » 21 Oct 2017, 07:34

Maksel,
запуск сессии:
[2017-10-20 16:47:52.956] ipoe27: 00000000000ACAE6: recv [DHCPv4 Request xid=c228e797 chaddr=f8:d1:11:8e:5d:b9 <Message-Type Request> <Request-IP 10.1.142.102> <Server-ID 10.1.128.1> <Max-Message-Size 1024> <Request-List Subnet,Router,Vendor-Specific,44,46,47,DNS,Route,Classless-Route,249> <Host-Name WR340G> <Vendor-Class 4d534654203938005f> <Client-ID 01f8d1118e5db9> <Relay-Agent {Agent-Circuit-ID _000400720019} {Agent-Remote-ID _ 0006ec228025b5e0}>]

чуть позже:
[2017-10-20 16:47:54.446] ipoe27: 00000000000ACAE6: recv [DHCPv4 Discover xid=4552604a chaddr=e8:94:f6:6f:1a:e1 <Message-Type Discover> <Max-Mess age-Size 1024> <Client-ID 01e894f66f1ae1> <Host-Name TL-WR741ND> <Vendor-Class 4d53465420352e30> <Request-IP 10.1.136.154> <Request-List Subnet,R outer,DNS,Domain-Name,Route,Vendor-Specific,44,46,47,Classless-Route,249> <Relay-Agent {Agent-Circuit-ID _000400720019} {Agent-Remote-ID _0006ec228025b5e0}>]
т.е. судя по данным опции 82 это один и тот-же коммутатор и порт, поэтому и "mac change detected"

Maksel
Posts: 14
Joined: 18 Jul 2015, 16:25
Location: UA, Krivoy Rog
Contact:

Re: проблема с интерфейсами IPOE

Post by Maksel » 21 Oct 2017, 10:46

Да. У меня магистральные кольца, местами до 8 свитчей в одном плече RSTP(знаю так нельзя, но...) построено на L2 коммутаторы D-Link.
Использую dhcp_local_relay чтобы потом в логах сервера понимать в каком магистральном порту MAC адрес абонента, потом проще искать. Плюс есть дома, где заняты все порты в L2 коммутаторе, заменить на новый L2 или добавить еще один свитч, нецелесообразно. Мы включаем в 24 порт обычный свитч и включаем в него абонентов с маленькими тарифами. И на таких свитчах также включено dhcp_local_relay. Также есть целые цепочки домов с неуправляемыми свитчами. Везде PPPoE. И dhcp_local_relay включаем на магистрали чтобы понимать если бон получит локальный IP, какие в этом или том направлении.
В планах "<Relay-Agent {Agent-Circuit-ID _000400720019} {Agent-Remote-ID _0006ec228025b5e0}>" использовать для получения UserName, пока же у меня UserName это VLAN-MAC

Code: Select all

сat  accel-ppp.lua
function username_vlan_mac(pkt)
    return pkt:ifname()..'-'..pkt:hdr('chaddr')
end
есть только миг, между прошлым и будущим, именно он называется - ping.

Maksel
Posts: 14
Joined: 18 Jul 2015, 16:25
Location: UA, Krivoy Rog
Contact:

Re: проблема с интерфейсами IPOE

Post by Maksel » 21 Oct 2017, 11:06

Еще заменит пробелу в ротацией логов.
Вот так запускаю accel

Code: Select all

/usr/local/accel-ppp/sbin/accel-pppd -d -c /etc/accel-ppp-ipoe-local.conf -p /run/accel-pppd-ipoe-local.pid
Вот файл /etc/logrotate.d/accel-ppp
Спойлер

Code: Select all

nas102:/etc# cat /etc/logrotate.d/accel-ppp
/var2/log/accel-ppp/*.log {
        missingok
        daily
        rotate 5
        compress
#       delaycompress
        sharedscripts
        postrotate
                test -r /run/accel-pppd.pid && kill -HUP `cat /run/accel-pppd.pid`
                test -r /run/accel-pppd-ipoe-local.pid && kill -HUP `cat /run/accel-pppd-ipoe-local.pid`
        endscript
}
Файлы ротейтятся
Спойлер

Code: Select all

-rw------- 1 root root 643993426 окт 21 14:01 local-accel-ppp.log
-rw------- 1 root root  93461695 окт 21 07:38 local-accel-ppp.log.1.gz
-rw------- 1 root root   1031097 окт 21 14:01 local-auth-fail.log
-rw------- 1 root root    234349 окт 21 07:37 local-auth-fail.log.1.gz
-rw-r--r-- 1 root root 231853088 окт 21 14:01 local-debug.log
-rw-r--r-- 1 root root 112931606 окт 21 07:38 local-debug.log.1.gz
-rw-r--r-- 1 root root         0 окт 21 07:38 local-emerg.log
-rw-r--r-- 1 root root        20 окт 20 07:37 local-emerg.log.1.gz
Но если файл local-accel-ppp.log и local-auth-fail.log наполняются сразу, а вот local-debug.log - пустой пока не сдаешь reload (делаю чере telnet 127.0.0.1 2085)
local-emerg.log не известно, он всегда пустой.
есть только миг, между прошлым и будущим, именно он называется - ping.

Dmitry
Администратор
Posts: 949
Joined: 09 Oct 2014, 10:06

Re: проблема с интерфейсами IPOE

Post by Dmitry » 21 Oct 2017, 12:41

в таком случае:
[ipoe]
check-mac-change=0

debug.log действительно не ротируется
если есть необходимость его отчистить, то выполнить echo > debug.log

Maksel
Posts: 14
Joined: 18 Jul 2015, 16:25
Location: UA, Krivoy Rog
Contact:

Re: проблема с интерфейсами IPOE

Post by Maksel » 22 Oct 2017, 16:10

Dmitry wrote:
21 Oct 2017, 12:41
в таком случае:
[ipoe]
check-mac-change=0

debug.log действительно не ротируется
если есть необходимость его отчистить, то выполнить echo > debug.log
check-mac-change=0 - помогло с 1300 уже сессии 1800+

После ротации логов, файлы accel-ppp.log auth-fail.log появляются сразу после kill -HUP pid
А вот файлы debug.log и emerg.log появляются уже после reload.
Т.е. вопрос не в том что очистить, а что данных - нет после kill -HUP
есть только миг, между прошлым и будущим, именно он называется - ping.

Dmitry
Администратор
Posts: 949
Joined: 09 Oct 2014, 10:06

Re: проблема с интерфейсами IPOE

Post by Dmitry » 23 Oct 2017, 05:24

потому что logratate их ротирует, а этого делать не надо

green
Posts: 7
Joined: 27 Oct 2016, 06:00

Re: проблема с интерфейсами IPOE

Post by green » 25 Oct 2017, 06:55

Добрый день всем!
Так и не могу победить :( Схема следующая: влан на клиента, далее q-in-q до accel.
Система на сервере
Спойлер
uname -a
Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.43-2+deb8u5 (2017-09-19) i686 GNU/Linux
Настройки accel-ppp.conf
Спойлер
[modules]
log_file

ipoe

radius

ippool

shaper
vlan-mon
#logwtmp
#connlimit

[core]
log-error=/var/log/accel-ppp/core.log
thread-count=4

[common]
single-session=replace
sid-case=upper
sid-source=seq
#max-sessions=1000

[ipoe]
verbose=5
username=ifname
#password=username
lease-time=600
renew-time=600
max-lease-time=3600
l4-redirect-ipset=100
shared=0
ifcfg=1
mode=L2
start=dhcpv4
gw-ip-address=10.32.254.1
ip-unnumbered=1
proxy-arp=2
nat=0
proto=100
attr-dhcp-opt82=DHCP-Option82
attr-l4-redirect=L4-Redirect
vlan-mon=re:eth0\.216.*
vlan-timeout=60
vlan-name=%I.%N
interface=re:eth0\.216.*,mtu=1490

[dns]
dns1=10.32.255.16
dns2=10.32.255.17

[radius]
sid_in_auth=1
dictionary=/usr/local/share/accel-ppp/radius/dictionary
nas-identifier=Accel-IPoE
nas-ip-address=10.132.0.9
gw-ip-address=10.32.254.1/24
server=10.132.0.4,test,auth-port=1812,acct-port=1813,req-limit=50,fail-timeout=0,max-fail=10,weight=1
dae-server=127.0.0.1:3799,test
verbose=1
timeout=10
max-try=3
acct-timeout=120
#acct-delay-time=0
acct-on=1
#attr-tunnel-type=My-Tunnel-Type

[ip-pool]
gw-ip-address=10.32.254.1
#vendor=Cisco
#attr=Cisco-AVPair
attr=Framed-Pool
10.32.254.2-254

[log]
log-file=/var/log/accel-ppp/accel-ppp.log
log-emerg=/var/log/accel-ppp/emerg.log
log-fail-file=/var/log/accel-ppp/auth-fail.log
log-debug=/var/log/accel-ppp/debug.log
#syslog=accel-pppd,daemon
#log-tcp=127.0.0.1:3000
copy=1
#color=1
#per-user-dir=per_user
#per-session-dir=per_session
#per-session=1
level=5

[shaper]
verbose=1
attr=Filter-Id
ifb=ifb0
up-limiter=htb
down-limiter=htb
cburst=1375000
r2q=10
quantum=1500
leaf-qdisc=sfq perturb 10
fwmark=38

[cli]
verbose=1
telnet=127.0.0.1:2000
tcp=127.0.0.1:2001
#password=123

[connlimit]
limit=10/min
burst=3
timeout=60
Вот лог работы
Спойлер
[2017-10-25 09:18:45.459] open ns (null)
[2017-10-25 09:18:45.461] ipoe: start interface eth0.216 (mtu=1490)
[2017-10-25 09:18:45.553] accel-ppp version ec3d2f2942172d79fe74a01f5c980873e01ff5dd
[2017-10-25 09:18:45.554] send [RADIUS(1) Accounting-Request id=1 <Acct-Status-Type Accounting-On> <NAS-Identifier "Accel-IPoE"> <NAS-IP-Address 10.132.0.9>]
[2017-10-25 09:18:45.554] recv [RADIUS(1) Accounting-Response id=1]
[2017-10-25 09:18:49.052] vlan-mon: notify 5 101 0800 0
[2017-10-25 09:18:49.052] ipoe: create vlan eth0.216.101 parent eth0.216
[2017-10-25 09:18:49.053] ipoe: start interface eth0.216.101 (mtu=1490)
[2017-10-25 09:18:52.095] eth0.216.101: : recv [DHCPv4 Discover xid=319483af chaddr=e4:8d:8c:b1:f3:25 <Message-Type Discover> <Request-List Subnet,Classless-Route,Router,Route,DNS,NTP,138,Vendor-Specific> <Host-Name MikroTik> <Client-ID 01e48d8cb1f325> <Relay-Agent {Agent-Circuit-ID _00650101} {Agent-Remote-ID _e0d9e3c45900}>]
[2017-10-25 09:18:52.106] eth0.216.101: 7F2779B53A7F2AD2: radius(1): req_enter 1
[2017-10-25 09:18:52.106] eth0.216.101: 7F2779B53A7F2AD2: send [RADIUS(1) Access-Request id=1 <User-Name "eth0.216.101"> <NAS-Identifier "Accel-IPoE"> <NAS-IP-Address 10.132.0.9> <NAS-Port 10> <NAS-Port-Id "eth0.216.101"> <NAS-Port-Type Ethernet> <Calling-Station-Id "e4:8d:8c:b1:f3:25"> <Called-Station-Id "eth0.216.101"> <DHCP-Option82> <Acct-Session-Id "7F2779B53A7F2AD2"> <User-Password>]
[2017-10-25 09:18:52.119] eth0.216.101: 7F2779B53A7F2AD2: radius(1): req_exit 0
[2017-10-25 09:18:52.119] eth0.216.101: 7F2779B53A7F2AD2: recv [RADIUS(1) Access-Accept id=1 <Session-Timeout 86400> <Service-Type Framed-User> <Framed-Protocol PPP> <Class> <Acct-Interim-Interval 60> <Filter-Id "102400">]
[2017-10-25 09:18:52.119] eth0.216.101: 7F2779B53A7F2AD2: eth0.216.101: authentication succeeded
[2017-10-25 09:18:52.119] eth0.216.101: 7F2779B53A7F2AD2: send [DHCPv4 Offer xid=319483af yiaddr=10.32.254.2 chaddr=e4:8d:8c:b1:f3:25 <Message-Type Offer> <Server-ID 10.32.254.1> <Lease-Time 600> <T1 600> <Router 10.32.254.1> <Subnet 255.255.255.255> <DNS 10.32.255.16,10.32.255.17>]
[2017-10-25 09:18:52.127] eth0.216.101: 7F2779B53A7F2AD2: recv [DHCPv4 Request xid=319483af chaddr=e4:8d:8c:b1:f3:25 <Message-Type Request> <Server-ID 10.32.254.1> <Request-IP 10.32.254.2> <Request-List Subnet,Classless-Route,Router,Route,DNS,NTP,138,Vendor-Specific> <Host-Name MikroTik> <Client-ID 01e48d8cb1f325> <Relay-Agent {Agent-Circuit-ID _00650101} {Agent-Remote-ID _e0d9e3c45900}>]
[2017-10-25 09:18:52.127] eth0.216.101: 7F2779B53A7F2AD2: port change detected
[2017-10-25 09:18:52.127] eth0.216.101: 7F2779B53A7F2AD2: terminate
[2017-10-25 09:18:52.129] eth0.216.101: 7F2779B53A7F2AD2: ipoe: session finished
может быть я что-то в конфиге не правильно делаю?
или что-то не хватает в системе?
опции сборки
Спойлер
-DKDIR=/usr/src/linux-headers-`uname -r` -DBUILD_DRIVER=TRUE -DRADIUS=TRUE -DNETSNMP=FALSE -DSHAPER=TRUE -DLOG_PGSQL=FALSE -DLUA=TRUE -DBUILD_IPOE_DRIVER=TRUE -DBUILD_VLAN_MON_DRIVER=TRUE

Dmitry
Администратор
Posts: 949
Joined: 09 Oct 2014, 10:06

Re: проблема с интерфейсами IPOE

Post by Dmitry » 25 Oct 2017, 07:23

green,
commit 34fac264e132d436f2405da114d4291555cd339f

green
Posts: 7
Joined: 27 Oct 2016, 06:00

Re: проблема с интерфейсами IPOE

Post by green » 25 Oct 2017, 12:02

И все же не выходит :(
Спойлер
[2017-10-25 14:59:46.327] open ns (null)
[2017-10-25 14:59:46.329] ipoe: start interface eth0.216 (mtu=1490)
[2017-10-25 14:59:46.385] accel-ppp version 34fac264e132d436f2405da114d4291555cd339f
[2017-10-25 14:59:46.386] send [RADIUS(1) Accounting-Request id=1 <Acct-Status-Type Accounting-On> <NAS-Identifier "Accel-IPoE"> <NAS-IP-Address 10.132.0.9>]
[2017-10-25 14:59:46.386] recv [RADIUS(1) Accounting-Response id=1]
[2017-10-25 14:59:49.646] vlan-mon: notify 7 101 0800 0
[2017-10-25 14:59:49.646] ipoe: create vlan eth0.216.101 parent eth0.216
[2017-10-25 14:59:49.647] ipoe: start interface eth0.216.101 (mtu=1490)
[2017-10-25 14:59:56.189] eth0.216.101: : recv [DHCPv4 Discover xid=1164938d chaddr=e4:8d:8c:b1:f3:25 <Message-Type Discover> <Request-List Subnet,Classless-Route,Router,Route,DNS,NTP,138,Vendor-Specific> <Host-Name MikroTik> <Client-ID 01e48d8cb1f325> <Relay-Agent {Agent-Circuit-ID _00650101} {Agent-Remote-ID _e0d9e3c45900}>]
[2017-10-25 14:59:56.190] eth0.216.101: 7F2779B53A7F4258: terminate
[2017-10-25 14:59:56.190] eth0.216.101: 7F2779B53A7F4258: ipoe: session finished
[2017-10-25 14:59:58.942] eth0.216.101: : recv [DHCPv4 Discover xid=1164938d chaddr=e4:8d:8c:b1:f3:25 <Message-Type Discover> <Request-List Subnet,Classless-Route,Router,Route,DNS,NTP,138,Vendor-Specific> <Host-Name MikroTik> <Client-ID 01e48d8cb1f325> <Relay-Agent {Agent-Circuit-ID _00650101} {Agent-Remote-ID _e0d9e3c45900}>]
[2017-10-25 14:59:58.943] eth0.216.101: 7F2779B53A7F4259: terminate
[2017-10-25 14:59:58.943] eth0.216.101: 7F2779B53A7F4259: ipoe: session finished
Может быть что-то я упустил ?

Dmitry
Администратор
Posts: 949
Joined: 09 Oct 2014, 10:06

Re: проблема с интерфейсами IPOE

Post by Dmitry » 25 Oct 2017, 12:25

в конфиге ничего не изменилось ?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest