Не работает ипое

IPoE related questions
Cramac
Posts: 98
Joined: 05 Jan 2017, 11:53
Contact:

Re: Не работает ипое

Post by Cramac » 24 Jan 2017, 15:39

На новом сервере с новым accel, да.
Может что то изменилось в логике? И то что попало в ipset надо фильтровать через iptables?

Dmitry
Администратор
Posts: 954
Joined: 09 Oct 2014, 10:06

Re: Не работает ипое

Post by Dmitry » 24 Jan 2017, 15:42

а, так у тебя же l4-redirect-on-reject стоит
так естественно этот трафик пропускается, иначе как редирект будет работать

Cramac
Posts: 98
Joined: 05 Jan 2017, 11:53
Contact:

Re: Не работает ипое

Post by Cramac » 24 Jan 2017, 15:54

все, да, мой косяк, забыл совсем.
ипсет то есть, а в иптаблес правила редиректа нет. Вот трафик и ходит свободно в интернет.

Cramac
Posts: 98
Joined: 05 Jan 2017, 11:53
Contact:

Re: Не работает ипое

Post by Cramac » 24 Jan 2017, 16:05

Осталось проверить, как будет работать совместно с впн.

Cramac
Posts: 98
Joined: 05 Jan 2017, 11:53
Contact:

Re: Не работает ипое

Post by Cramac » 26 Jan 2017, 10:27

Тогда все же вопрос про сети из секции ipoe

указано
local-net=10.10.11.0/24
почему тогда пытается авторизовать клиентов с 10.10.10.0/24 ?

dimka88
Posts: 728
Joined: 13 Oct 2014, 05:51
Contact:

Re: Не работает ипое

Post by dimka88 » 26 Jan 2017, 11:10

Возможно примитивный вопрос, но все же, рестарт делали? =)

Cramac
Posts: 98
Joined: 05 Jan 2017, 11:53
Contact:

Re: Не работает ипое

Post by Cramac » 26 Jan 2017, 11:40

да, у меня было две сети прописаны, эта и еще 172.0.0.0/8
172 закоментировал, сделал релоад, обрабатывать перестал ее. но 172 была вся прописана, поэтому не ясно было правильно ли обрабатывает..

но 10.10.11 была и релоад делал несколько раз и перезагружал и сервер и accel и все равно

Cramac
Posts: 98
Joined: 05 Jan 2017, 11:53
Contact:

Re: Не работает ипое

Post by Cramac » 26 Jan 2017, 14:08

и еще в догонку:
у меня сеть работает на pptp и хочу постепенно переводить на ipoe
все вроде как настроено и pptp работает и ipoe работает, НО
добавив редирект
iptables -t nat -A PREROUTING -p tcp -m set --match-set l4redirect src -j REDIRECT --to-ports 8001

те кто попадает в l4redirect не могут подключится по pptp, а без этого правила не работает редирект... Как можно решить?

П.С. этот вопрос решил, добавив (адрес сервера)
iptables -t nat -I PREROUTING -d 10.10.10.1/32 -p tcp -m set --match-set l4redirect src -j ACCEPT

в такой схеме все попадут в l4redirect если они не работают по ipoe в то же время они могут подключится по pptp и спокойно работать.

Cramac
Posts: 98
Joined: 05 Jan 2017, 11:53
Contact:

Re: Не работает ипое

Post by Cramac » 28 Jan 2017, 16:05

Есть мысли по работе local-net ? Почему берет не то что указано?

Cramac
Posts: 98
Joined: 05 Jan 2017, 11:53
Contact:

Re: Не работает ипое

Post by Cramac » 29 Jan 2017, 10:25

Подскажите еще до кучи, в каком режиме надо ипое, что бы в качестве Calling-Station-Id передавался ИП адрес абонента?

пробовал ставить L2 и L3 делал релоад, но видимо релоад не влияет на это

Сейчас оно выглядит так:

Code: Select all

[2017-01-29 13:17:20]:  info: ipoe65: send [RADIUS(1) Access-Request id=1 <User-Name "172.20.34.36"> <NAS-Identifier "accel-ppp"> <NAS-IP-Address 10.10.10.1> <NAS-Port 119098> <NAS-Port-Id "ipoe65"> <NAS-Port-Type Ethernet> <Calling-Station-Id "00:12:cf:39:97:40"> <Called-Station-Id "ens6f0"> <Framed-IP-Address 172.20.34.36> <User-Password>]
Calling-Station-Id "00:12:cf:39:97:40" - мак маршрутизатора

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest