custom attributes

Shaper related questions
Post Reply
mlemaitre
Posts: 17
Joined: 04 Dec 2014, 15:09

custom attributes

Post by mlemaitre » 30 Jan 2017, 11:18

Hi,

I'm trying to use the build-in shaper with custom attributes WISPr-Bandwidth-Max-Down and WISPr-Bandwidth-Max-Up from freeradius wisp dictionary.
In accel-ppp.conf, I set attr-down to WISPr-Bandwidth-Max-Down and attr-up to WISPr-Bandwidth-Max-Up, as in the wiki, but when I restart the daemon, I get this error in the emerg log:

shaper: incorrect attribute(s), tbf disabled...

looking at the code, it looks to me like it expects attr-down and up to be integers:

Code: Select all

                if (conf_attr_up <= 0 || conf_attr_down <= 0) {
                        log_emerg("shaper: incorrect attribute(s), tbf disabled...\n");
                        return;
where am I wrong, and how should I set the shaper up ?

Thanks,

Mat

Dmitry
Администратор
Posts: 671
Joined: 09 Oct 2014, 10:06

Re: custom attributes

Post by Dmitry » 30 Jan 2017, 12:09

hi
did you also specify vendor=WISPr ?

mlemaitre
Posts: 17
Joined: 04 Dec 2014, 15:09

Re: custom attributes

Post by mlemaitre » 30 Jan 2017, 12:27

hi,

nope.
I just tried, and the message is gone.
However, how can I check if the shaper is in place ?
I tried "tc qdisc show dev ppp0", but it only shows a fifo, is it attached to an other interface ?

thanks,

Dmitry
Администратор
Posts: 671
Joined: 09 Oct 2014, 10:06

Re: custom attributes

Post by Dmitry » 30 Jan 2017, 13:25

check logs with verbose=1 and level=4

mlemaitre
Posts: 17
Joined: 04 Dec 2014, 15:09

Re: custom attributes

Post by mlemaitre » 30 Jan 2017, 13:49

well, it looks good :

info: ppp0: shaper: installed shaper 6144/256 (Kbit)

but I found that I have an other problem:

warn: shaper: requested 'htb' upstream limiter, but no 'ifb' specified, falling back to police...

and if I try to uncomment ifb=ifb0, then the daemon doesn't start at all.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest