L2TP performance

L2TP related questions
Post Reply
tj-19
Posts: 28
Joined: 10 Jun 2019, 20:42

L2TP performance

Post by tj-19 » 20 Apr 2022, 14:23

Hi all,

I was just wondering if anyone is using ACCEL with L2TP and 1 Gbps connections.

I have a test server running using a 40 Gbps - XL710-QDA1 NIC.

The CPU usage is very low and I am using 8 cores.

But the throughput is only around 300 Mbps.

I've tried setting NIC optimisation, such as ethtool -K enp1s0 gso off gro off tso off

Is there any support for DDP (Dynamic Device Personalization) ?

Any ideas?

dimka88
Posts: 817
Joined: 13 Oct 2014, 05:51
Contact:

Re: L2TP performance

Post by dimka88 » 27 Apr 2022, 11:19

Hi @tj-19, I think in this case it will related to CPU frequency. Try to disable HT, set CPU policy (scaling governor) to performance. Also try to disable mitigations, like meltdown and spectre 1 and 2

tj-19
Posts: 28
Joined: 10 Jun 2019, 20:42

Re: L2TP performance

Post by tj-19 » 28 Apr 2022, 14:59

Hi,

The CPU is a Xeon E5-2440 which runs at 2.40 GHz.

I disabled Hyperthreading, set the SG and disabled the suggested mitigations.

In all cases the overall CPU is very low.

What is the relation between the frequency and performance in this case?

Many thanks for your help.

dimka88
Posts: 817
Joined: 13 Oct 2014, 05:51
Contact:

Re: L2TP performance

Post by dimka88 » 29 Apr 2022, 19:56

Hi @tj-19, CPU frequency related to flow speed. Did you try to test speed with speedtest multiflow mode?
Could you show `top` command output and press `1` when you doing test?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest