So I had put accel-ppp live with heavy load

PPPoE related questions
hashbang
Posts: 63
Joined: 12 Jul 2015, 10:28

Re: So I had put accel-ppp live with heavy load

Post by hashbang » 07 May 2020, 15:20

Hi,
TY. Sorry for delayed response
hashbang,auth-port=1812,acct-port=1813,req-limit=50,fail-timeout=0,max-fail=10,weight=1
verbose=1
acct-interim-interval=300
timeout=3
max-try=3
acct-timeout=360
#acct-delay-time=0
#acct-on=0
#attr-tunnel-type=My-Tunnel-Type
thanks

hashbang
Posts: 63
Joined: 12 Jul 2015, 10:28

Re: So I had put accel-ppp live with heavy load

Post by hashbang » 18 May 2020, 15:36

Hi,
Crashed again
1) OS was up
2) CPU usage was minimal
3) accel-cmd show stat-- stuck
4) Missing logs of that time (restarted the services at 18:xx) :

Port-Type Virtual> <Service-Type Framed-User> <Framed-Protocol PPP> <Calling-Station-Id "04:95:e6:30:3b:58"> <Called-Station-Id "00:1b:21:57:ba:80"> <User-Password 0x57a204a4f42a80ea461f8041a45435aa>]
[2020-05-18 17:38:45]: info: pppoe2971: send [RADIUS(1) Accounting-Request id=1 <User-Name "gcajay"> <NAS-Identifier "Hashbang"> <NAS-IP-Address 103.208.153.203> <NAS-Port 2856> <NAS-Port-Id "pppoe2971"> <NAS-Port-Type Virtual> <Service-Type Framed-User> <Framed-Protocol PPP> <Calling-Station-Id "a0:ab:1b:c2:15:01"> <Called-Station-Id "00:1b:21:57:ba:80"> <Acct-Status-Type Start> <Acct-Authentic RADIUS> <Acct-Session-Id "00000000007ab7d6"> <Acct-Session-Time 0> <Acct-Input-Octets 0> <Acct-Output-Octets 0> <Acct-Input-Packets 0> <Acct-Output-Packets 0> <Acct-Input-Gigawords 0> <Acct-Output-Gigawords 0> <Framed-IP-Address 100.90.56.229>]
[2020-05-18 17:38:45]: info: pppoe2971: recv [RADIUS(1) Accounting-Response id=1]

[2020-05-18 18:06:52]: info: terminate, sig = 15
[2020-05-18 18:12:28]: warn: failed to load vlan_mon module
5) monitoring traffic on interface stuck (Bmon)
6) PPPOE users were up seen through ip command
7) accel-cmd show sessions (stuck)

some nms graphs if it maybe of any help. Logs stopped at 17:38 and plz see see the graphs around that time.
Screenshot from 2020-05-18 20-41-29.png
Screenshot from 2020-05-18 20-41-29.png (135.95 KiB) Viewed 93 times
thanks and regards

dimka88
Posts: 703
Joined: 13 Oct 2014, 05:51
Contact:

Re: So I had put accel-ppp live with heavy load

Post by dimka88 » 19 May 2020, 10:42

Who kills accel-ppp? Check please journalctl. Maybe systemd or ...

hashbang
Posts: 63
Joined: 12 Jul 2015, 10:28

Re: So I had put accel-ppp live with heavy load

Post by hashbang » 19 May 2020, 11:31

Hi,
TY

[2020-05-18 18:06:52]: info: terminate, sig = 15 if your talking about this then I did a restart at this time.

thanks

dimka88
Posts: 703
Joined: 13 Oct 2014, 05:51
Contact:

Re: So I had put accel-ppp live with heavy load

Post by dimka88 » 19 May 2020, 12:29

Ah, ok.
You need to check `ps ax | grep accel` first.
Show me `dmesg -T` and `journalctl` 2020-05-18 from 17:00 to 18:30

hashbang
Posts: 63
Joined: 12 Jul 2015, 10:28

Re: So I had put accel-ppp live with heavy load

Post by hashbang » 19 May 2020, 19:39

hi
ty
i'd done reboot at 18:10 so sending u till 18:00 hrs
https://gofile.io/d/kWlaFI
thanks

hashbang
Posts: 63
Joined: 12 Jul 2015, 10:28

Re: So I had put accel-ppp live with heavy load

Post by hashbang » 24 May 2020, 07:37

Hi,
Plz find link of dmesg and journal of 23rd may
https://gofile.io/d/Ep8Xzz
thanks

hashbang
Posts: 63
Joined: 12 Jul 2015, 10:28

Re: So I had put accel-ppp live with heavy load

Post by hashbang » 24 May 2020, 11:06

Hi,
It seems like when there is a flapping in some part of network.
accel is unable to handle so many request
After sometimes it restarts by itself so creating a mess in itself and radius (increased number of start sessions )
if it recovers then interim update stops
else systemctl shutdown accel-ppp wait for some seconds
start the services.
this is my deduction
thanks

dimka88
Posts: 703
Joined: 13 Oct 2014, 05:51
Contact:

Re: So I had put accel-ppp live with heavy load

Post by dimka88 » 24 May 2020, 18:44

Hi @hashbang, please set up your firewall at first. I see in your log a very odd situation.

Code: Select all

May 23 15:49:41 hbbras00 polkitd[2088]: Registered Authentication Agent for unix-process:7851:122129258 (system bus name :1.5085 [/usr/bin/pkttyagent --notify-fd 5 --fallback], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_IN)
May 23 15:49:41 hbbras00 systemd[1]: Stopping Accel-PPP...
Note; In your `dmesg` output I don't see accel-ppp core dump information, which means accel-ppp daemon finish with normal code (not segfault).
I segfault case, I will recommend to build accel-ppp with additional DEBUG flags and run in GDB https://accel-ppp.readthedocs.io/en/lat ... index.html

hashbang
Posts: 63
Joined: 12 Jul 2015, 10:28

Re: So I had put accel-ppp live with heavy load

Post by hashbang » 25 May 2020, 06:48

dimka88 wrote:
24 May 2020, 18:44
Hi @hashbang, please set up your firewall at first. I see in your log a very odd situation.

Code: Select all

May 23 15:49:41 hbbras00 polkitd[2088]: Registered Authentication Agent for unix-process:7851:122129258 (system bus name :1.5085 [/usr/bin/pkttyagent --notify-fd 5 --fallback], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_IN)
May 23 15:49:41 hbbras00 systemd[1]: Stopping Accel-PPP...
Note; In your `dmesg` output I don't see accel-ppp core dump information, which means accel-ppp daemon finish with normal code (not segfault).
I segfault case, I will recommend to build accel-ppp with additional DEBUG flags and run in GDB https://accel-ppp.readthedocs.io/en/lat ... index.html
Hi,
TY,
This was restart done by me at 15:49 as there was no option left. Please see the graphs. Interim updates stopped at 15:07
Screenshot from 2020-05-25 12-08-14.png
Screenshot from 2020-05-25 12-08-14.png (120.38 KiB) Viewed 48 times
thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest