Спонтанное отключение всех IPoE интерфейсов

IPoE related questions
dimka88
Posts: 464
Joined: 13 Oct 2014, 05:51
Contact:

Re: Спонтанное отключение всех IPoE интерфейсов

Post by dimka88 » 12 Jun 2018, 10:06

dimka88 wrote:
12 Jun 2018, 09:46
Вы пробовали подгружать igb с debug?

Code: Select all

modprobe -r igb && modprobe igb debug=16
После этого нужно будет поднять интерфейс снова.

KovAl
Posts: 79
Joined: 26 Dec 2017, 15:35

Re: Спонтанное отключение всех IPoE интерфейсов

Post by KovAl » 12 Jun 2018, 10:28

dimka88 wrote:
12 Jun 2018, 10:06

Code: Select all

modprobe -r igb && modprobe igb debug=16
После этого нужно будет поднять интерфейс снова.
Надо подумать.. Дело в том, что в данный момент я "общаюсь" с сервером по-удалёнке, а modprobe -r явно лишит доступа.
Тут даже nohup вряд ли спасёт.
Разве-что скрипт наваять и запустить по cron-у, либо отложить сие до завтра..
Кстати, а куда будет писаться debug? В messages, или надо где-то указать файл лога?

dimka88
Posts: 464
Joined: 13 Oct 2014, 05:51
Contact:

Re: Спонтанное отключение всех IPoE интерфейсов

Post by dimka88 » 12 Jun 2018, 13:24

KovAl wrote:
12 Jun 2018, 10:28
Кстати, а куда будет писаться debug? В messages, или надо где-то указать файл лога?
Должен в messages или kernel.log

KovAl
Posts: 79
Joined: 26 Dec 2017, 15:35

Re: Спонтанное отключение всех IPoE интерфейсов

Post by KovAl » 13 Jun 2018, 13:11

dimka88 wrote:
12 Jun 2018, 13:24
KovAl wrote:
12 Jun 2018, 10:28
Кстати, а куда будет писаться debug? В messages, или надо где-то указать файл лога?
Должен в messages или kernel.log
Перезагрузил, но что-то совсем ничего не вижу в логах, кроме записей, созданных при старте..

KovAl
Posts: 79
Joined: 26 Dec 2017, 15:35

Re: Спонтанное отключение всех IPoE интерфейсов

Post by KovAl » 16 Jun 2018, 19:46

Очередной писец..
Ничего нового.
От igb вообще ничего, все сообщения в момент падения eth0 касаются ipv6..
Это в messages, аналогично в kern.log

Code: Select all

Jun 16 19:09:02 ipoe-nas1 kernel: IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Jun 16 19:09:02 ipoe-nas1 kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Jun 16 19:09:02 ipoe-nas1 kernel: IPv6: ADDRCONF(NETDEV_UP): eth0.3612: link is not ready
Jun 16 19:09:02 ipoe-nas1 kernel: IPv6: ADDRCONF(NETDEV_UP): eth0.3612.101: link is not ready
Jun 16 19:09:02 ipoe-nas1 kernel: IPv6: ADDRCONF(NETDEV_UP): eth0.3612.102: link is not ready
....
Jun 16 19:09:05 ipoe-nas1 kernel: igb 0000:02:00.0 eth0: igb: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
Jun 16 19:09:05 ipoe-nas1 kernel: IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Jun 16 19:09:05 ipoe-nas1 kernel: IPv6: ADDRCONF(NETDEV_CHANGE): eth0.3612: link becomes ready
Jun 16 19:09:05 ipoe-nas1 kernel: IPv6: ADDRCONF(NETDEV_CHANGE): eth0.3647: link becomes ready
Jun 16 19:09:05 ipoe-nas1 kernel: IPv6: ADDRCONF(NETDEV_CHANGE): eth0.3677: link becomes ready
В dmesg ВООБЩЕ НИЧЕГО.
До сегодня аналогично падало 14-го.
Что ещё и где ищем??

KovAl
Posts: 79
Joined: 26 Dec 2017, 15:35

Re: Спонтанное отключение всех IPoE интерфейсов

Post by KovAl » 18 Jun 2018, 14:13

Возможно, "потеряшку" нашёл.
Плюс ещё подобное.
К сожалению, только сегодня узнал, что
Intel® 82574_82583 Gigabit Ethernet Controller to I210_I211 – Design Guide
.
Целых три совпадения:
1. I210 == 82574
2. отключение интерфейса
3. "что-то странное", прилетевшее из сети.

Если бы знать ранее, что такое I210, то возможно и не было бы этой темы..
С закидонами 82574 я знаком давно и не по-наслышке, а тут ещё оказывается и "пакет смерти" для неё конкретно существует..
Видимо, Intel так и не сумел сделать конфетку из этого говна..

Заказал 82576, надеюсь "излечиться". Есть ещё, правда, сомнения по поводу того, что на "моей" материнке PCIEx живёт в процессоре,
но возможно, это уже из "обжегшись на молоке, дуем на холодную воду".

dimka88
Posts: 464
Joined: 13 Oct 2014, 05:51
Contact:

Re: Спонтанное отключение всех IPoE интерфейсов

Post by dimka88 » 18 Jun 2018, 18:52

Ждем колбэка по этой ситуации на 82576, думаю ваш опыт в этой теме точно кому то поможет!

KovAl
Posts: 79
Joined: 26 Dec 2017, 15:35

Re: Спонтанное отключение всех IPoE интерфейсов

Post by KovAl » 21 Jun 2018, 08:16

Сегодня (21.06.18) поставил сетевую 82576. Всё взлетело "на раз-два", тьфу-тьфу-тьфу 8-) .
Начинаем отсчёт. О результатах пока рано, т.к. с 17.06.18 до сегодняшнего дня всё работало без проблем на набортных I210.
На след. неделе планирую перевод ещё одного сегмента на IPoE, вот тогда и посмотрим..

KovAl
Posts: 79
Joined: 26 Dec 2017, 15:35

Re: Спонтанное отключение всех IPoE интерфейсов

Post by KovAl » 25 Jun 2018, 09:13

После очередного анализа возникающей ситуации и результатов проделанной работы, с акцентом на это -
KovAl wrote:
07 Jun 2018, 09:54
... отсутствие error/warning во ВСЕХ системных сообщениях, наводит на мысль, что eth0 отправляется в down ШТАТНО,
т.е. типа ifconfig eth0 down..
- появилось предположение - не моего ли изготовления этот "баг"..
Для начала задам "наводящий вопрос" - accel-cmd может УСПЕШНО выполнить команду "accel-cmd terminate if eth0", если такая ему вдруг поступит?
Именно eth0 (без влан).

nik247
Posts: 102
Joined: 11 Oct 2014, 15:57

Re: Спонтанное отключение всех IPoE интерфейсов

Post by nik247 » 25 Jun 2018, 11:15

KovAl wrote:
25 Jun 2018, 09:13
Для начала задам "наводящий вопрос" - accel-cmd может УСПЕШНО выполнить команду "accel-cmd terminate if eth0", если такая ему вдруг поступит?
Именно eth0 (без влан).
На стенде команда "accel-cmd terminate if eth0" принимается, но ничего не делает....
Впрочем ведет себя также, как и для не существующих интерфейсов....

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest