Problem whit accel-ppd when start

PPPoE related questions
Post Reply
villagenet
Posts: 5
Joined: 09 Jan 2019, 13:13

Problem whit accel-ppd when start

Post by villagenet » 10 Mar 2019, 07:50

Hi I have this problem when i reboot or shutdown server accel-ppp dont start

in /etc/init.d/accel status i have

● accel.service
Loaded: loaded (/etc/init.d/accel; generated; vendor preset: enabled)
Active: active (exited) since Sun 2019-03-10 09:36:32 EET; 2min 44s ago
Docs: man:systemd-sysv-generator(8)
Process: 3751 ExecStop=/etc/init.d/accel stop (code=exited, status=0/SUCCESS)
Process: 3784 ExecStart=/etc/init.d/accel start (code=exited, status=0/SUCCESS)
Tasks: 0 (limit: 4915)
CGroup: /system.slice/accel.service

Mar 10 09:36:32 billing1 systemd[1]: Starting accel.service...
Mar 10 09:36:32 billing1 accel[3784]: Starting PPtP/L2TP/PPPoE server: accel-pppd.
Mar 10 09:36:32 billing1 systemd[1]: Started accel.service.

in ps ax |grep accel

4617 pts/0 S+ 0:00 grep accel

cat /var/log/accel-ppp/accel-ppp.log

[2019-03-10 09:36:32]: warn: failed to load vlan_mon module
[2019-03-10 09:36:32]: debug: libnetlink: RTNETLINK answers: No such file or directory
[2019-03-10 09:36:32]: error: genl: error talking to kernelcat
[2019-03-10 09:36:32]: warn: vlan_mon: kernel module is not loaded

i dont use vlan_mon[modules]
log_file
#log_syslog
#log_tcp
#log_pgsql

#pptp
#l2tp
#sstp
pppoe
#ipoe

#auth_mschap_v2
#auth_mschap_v1
#auth_chap_md5
auth_pap

radius
#chap-secrets

pppd_compat

#shaper
#net-snmp
#logwtmp
#connlimit

#ipv6_nd
#ipv6_dhcp
#ipv6pool
ippool

[core]
log-error=/var/log/accel-ppp/core.log
thread-count=4

[common]
#single-session=replace
#sid-case=upper
#sid-source=seq
#max-sessions=1000

[ppp]
verbose=1
min-mtu=1280
mtu=1496
mru=1496
#accomp=deny
#pcomp=deny
ccp=0
check-ip=0
#mppe=require
ipv4=require
ipv6=allow
ipv6-intf-id=0:0:0:1
ipv6-peer-intf-id=0:0:0:2
ipv6-accept-peer-intf-id=1
lcp-echo-interval=20
lcp-echo-failure=3
lcp-echo-timeout=120
unit-cache=1
#unit-preallocate=1

[auth]
#any-login=0
#noauth=0

[pptp]
#verbose=1
#echo-interval=30
#ifname=pptp%d

[pppoe]
verbose=1
ac-name=pppoe2
#service-name=pppoe22
#pado-delay=0
#pado-delay=0,100:100,200:200,-1:500
called-sid=ifname
#tr101=1
#padi-limit=0
ip-pool=realip
#ifname=pppoe%d
sid-uppercase=1
vlan-mon=enp1s0f3,10-40
#vlan-timeout=60
#vlan-name=%I.%N
#interface=eth1,padi-limit=1000
#interface=eth0
#interface=re:enp1s0f3.([1-9]|[1-9][0-9]|[1-9][0-9][0-9]|[1-4][0-9][0-9][0-9]),padi-limit=10000
interface=enp1s0f3.11,padi-limit=1000
interface=enp1s0f3.12,padi-limit=1000
interface=enp1s0f3.13,padi-limit=1000
interface=enp1s0f3.14,padi-limit=1000
interface=enp1s0f3.15,padi-limit=1000
interface=enp1s0f3.16,padi-limit=1000
interface=enp1s0f3.17,padi-limit=1000
interface=enp1s0f3.18,padi-limit=1000
interface=enp1s0f3.19,padi-limit=1000
interface=enp1s0f3.20,padi-limit=1000
interface=enp1s0f3.21,padi-limit=1000
interface=enp1s0f3.22,padi-limit=1000
interface=enp1s0f3.26,padi-limit=1000
interface=enp1s0f3.27,padi-limit=1000
interface=enp1s0f3.28,padi-limit=1000
interface=enp1s0f3.29,padi-limit=1000
interface=enp1s0f3.30,padi-limit=1000
interface=enp1s0f3.31,padi-limit=1000
interface=enp1s0f3.32,padi-limit=1000
interface=enp1s0f3.33,padi-limit=1000
interface=enp1s0f3.34,padi-limit=1000

[l2tp]
#verbose=1
#dictionary=/usr/local/share/accel-ppp/l2tp/dictionary
#hello-interval=60
#timeout=60
#rtimeout=1
#rtimeout-cap=16
#retransmit=5
#recv-window=16
#host-name=accel-ppp
#dir300_quirk=0
#secret=
#dataseq=allow
#reorder-timeout=0
#ip-pool=l2tp
#ifname=l2tp%d

[dns]
dns1=8.8.8.8
dns2=8.8.4.4.4

[wins]
wins1=8.8.8.8
wins2=8.8.4.4

[radius]
dictionary=/usr/local/share/accel-ppp/radius/dictionary
nas-identifier=pppoe2-accel
nas-ip-address=127.0.0.1
gw-ip-address=10.10.10.1
server=127.0.0.1,testis,auth-port=1812,acct-port=1813,req-limit=50,fail-timeout=0,max-fail=5,weight=1
server=192.168.9.6,testis,auth-port=1812,acct-port=1813,req-limit=50,fail-timeout=0,max-fail=5,weight=1
dae-server=127.0.0.1:3799,testis
verbose=1
timeout=3
max-try=3
#acct-timeout=120
#acct-delay-time=0
#acct-on=0
#attr-tunnel-type=My-Tunnel-Type

[client-ip-range]
#10.0.0.0/8
disable

[ip-pool]
gw-ip-address=10.10.10.1

#vendor=Cisco
#attr=Cisco-AVPair

#attr=Framed-Pool
attr=Framed-IP-Address
10.10.151.1/24,name=pppoe2
10.10.150.1/24,name=pppoe
46.*.*.*/24,name=real2
85.*.*.*-85.*.*.*,name=realip,next=real2

[log]
log-file=/var/log/accel-ppp/accel-ppp.log
log-emerg=/var/log/accel-ppp/emerg.log
log-fail-file=/var/log/accel-ppp/auth-fail.log
log-debug=/var/log/accel-ppp/debug.log
#syslog=accel-pppd,daemon
#log-tcp=127.0.0.1:3000
copy=0
color=1
#per-user-dir=per_user
#per-session-dir=per_session
#per-session=1
level=5

[log-pgsql]
conninfo=user=log
log-table=log

[pppd-compat]
verbose=1
ip-pre-up=/etc/ppp/auth-up
ip-up=/etc/ppp/ip-up
ip-down=/etc/ppp/ip-down
#ip-change=/etc/ppp/ip-change
radattr-prefix=/var/run/radattr
#fork-limit=16

[chap-secrets]
#gw-ip-address=192.168.100.1
#chap-secrets=/etc/ppp/chap-secrets
#encrypted=0
#username-hash=md5

[shaper]
#attr=Filter-Id
#down-burst-factor=0.1
#up-burst-factor=1.0
#latency=50
#mpu=0
#mtu=0
#r2q=10
#quantum=1500
#moderate-quantum=1
#cburst=1534
#ifb=ifb0
#up-limiter=police
#down-limiter=tbf
#leaf-qdisc=sfq perturb 10
#leaf-qdisc=fq_codel [limit PACKETS] [flows NUMBER] [target TIME] [interval TIME] [quantum BYTES] [[no]ecn]
#rate-multiplier=1
#fwmark=1
#verbose=1

[cli]
verbose=1
telnet=127.0.0.1:2000
tcp=127.0.0.1:2001
#password=123
sessions-columns=ifname,username,ip,ip6,ip6-dp,type,state,uptime,uptime-raw,calling-sid,called-sid,sid,comp,rx-bytes,tx-bytes,rx-bytes-raw,tx-bytes-raw,rx-pkts,tx-pkts

[snmp]
master=0
agent-name=accel-ppp

[connlimit]
limit=10/min
burst=3
timeout=60

[ipv6-pool]
#gw-ip6-address=fc00:0:1::1
#fc00:0:1::/48,64
#delegate=fc00:1::/36,48

[ipv6-dns]
#fc00:1::1
#fc00:1::2
#fc00:1::3
#dnssl=suffix1.local.net
#dnssl=suffix2.local.net.

[ipv6-dhcp]
#verbose=1
#pref-lifetime=604800
#valid-lifetime=2592000
#route-via-gw=1


in cat /etc/accel-ppp.conf.dist

dimka88
Posts: 534
Joined: 13 Oct 2014, 05:51
Contact:

Re: Problem whit accel-ppd when start

Post by dimka88 » 10 Mar 2019, 09:14

Hi, errors about vlan_mon not critical, ignore this
[2019-03-10 09:36:32]: warn: failed to load vlan_mon module
[2019-03-10 09:36:32]: debug: libnetlink: RTNETLINK answers: No such file or directory
[2019-03-10 09:36:32]: error: genl: error talking to kernelcat
[2019-03-10 09:36:32]: warn: vlan_mon: kernel module is not loaded
at first change section [dns], delete digit in dns2 8.8.4.4.4

Code: Select all

[dns]
dns1=8.8.8.8
dns2=8.8.4.4
show accel-ppp.conf not accel.ppp.conf.dist
and logs /var/log/accel-ppp/emerge.log and /var/log/accel-ppp/core.log

ps:// community have telegram chat https://telegram.me/joinchat/DS6swRC3DvEWdNijTqaaeA for fast reaction

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests