[SOLVED]pppoe interfaces without ip address

PPPoE related questions
Post Reply
hashbang
Posts: 29
Joined: 12 Jul 2015, 10:28

[SOLVED]pppoe interfaces without ip address

Post by hashbang » 06 Feb 2020, 12:18

HI,
Conducting live test on pppoe server. I got issue tht some people were unable to reach internet. I found pppoe interface is up but no ip address on it whereas in show session the user was online with ip address. Details below :

pppoe5: flags=16<POINTOPOINT> mtu 1480
ppp txqueuelen 3 (Point-to-Point Protocol)
RX packets 20771 bytes 1521402 (1.4 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 24 bytes 432 (432.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


pppoe5 | nrlirshad1 | 04:95:e6:80:dd:88 | 100.90.48.248 | | pppoe | | active | 00:05:59
thanks
Last edited by hashbang on 11 Feb 2020, 05:57, edited 1 time in total.

dimka88
Posts: 624
Joined: 13 Oct 2014, 05:51
Contact:

Re: pppoe interfaces without ip address

Post by dimka88 » 06 Feb 2020, 20:32

Hi, this is radius user? Is ip-pool configured?
Do you have logs?
Which kernel and accel-ppp version running?

hashbang
Posts: 29
Joined: 12 Jul 2015, 10:28

Re: pppoe interfaces without ip address

Post by hashbang » 07 Feb 2020, 06:38

yes this is radius user
we already have 400 users online so ip pool is there (u can see it in show sessions in the post IP addr has been assigned)
its running on centos kernel 5.5.2 from elrepo
accel-ppp is latest just compiled 3 4 days back from git
------------------------------------

hashbang
Posts: 29
Joined: 12 Jul 2015, 10:28

Re: pppoe interfaces without ip address

Post by hashbang » 07 Feb 2020, 07:03

this happened again few users get ip from radius but on interface its blank
pppoe15 | nrlankur51 | 58:d5:6e:80:90:12 | 100.90.48.94 | | pppoe | | active | 01:37:53
-----------------
pppoe15: flags=16<POINTOPOINT> mtu 1492
ppp txqueuelen 3 (Point-to-Point Protocol)
RX packets 54044 bytes 5723670 (5.4 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 24 bytes 426 (426.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
----------------------------------------------------------------------------------
1) disconnected user from radius
2) ifconfig pppoe15 down gives no error but interface is up
3) deleted the interface with ip link del. IF is removed successfuly
4) User is logged in successfuly and there is ip on IF
-----------------------------------------------------------------------------------

pppoe286 | nrlankur51 | 58:d5:6e:80:90:12 | 100.90.48.65 | | pppoe | | active | 00:05:03

ifconfig pppoe15
pppoe15: flags=81<UP,POINTOPOINT,RUNNING> mtu 1480
inet 10.199.199.1 netmask 255.255.255.255 destination 100.90.48.94
ppp txqueuelen 3 (Point-to-Point Protocol)
RX packets 36585 bytes 2346967 (2.2 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 131555 bytes 188079454 (179.3 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

thanks

dimka88
Posts: 624
Joined: 13 Oct 2014, 05:51
Contact:

Re: pppoe interfaces without ip address

Post by dimka88 » 07 Feb 2020, 13:27

Hi, increase log level `[log]level=5` set verbose on all modules, like [ppp]verbose=1 and run accel-cmd reload
Also check journalctl and dmesg when session with this ip connected.

hashbang
Posts: 29
Joined: 12 Jul 2015, 10:28

Re: pppoe interfaces without ip address

Post by hashbang » 09 Feb 2020, 05:01

this interface got complaint just now undermentioned journalctl
eb 09 09:52:37 hbbras00 NetworkManager[1519]: <info> [1581222157.9336] manager: (pppoe1436): new Ppp device (/org/freedesktop/NetworkManager/Devices/7634)
Feb 09 09:52:37 hbbras00 NetworkManager[1519]: <info> [1581222157.9435] device (pppoe1436): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Feb 09 09:52:37 hbbras00 NetworkManager[1519]: <info> [1581222157.9948] device (pppoe1436): state change: unavailable -> unmanaged (reason 'connection-assumed', sys-iface-state: 'managed')
Feb 09 09:54:38 hbbras00 kernel: ppp1436: renamed from pppoe1436
Feb 09 09:54:38 hbbras00 NetworkManager[1519]: <info> [1581222278.6744] device (pppoe1436): interface index 7642 renamed iface from 'pppoe1436' to 'ppp1436'
Feb 09 09:54:55 hbbras00 kernel: pppoe1436: renamed from ppp1399
Feb 09 09:54:55 hbbras00 NetworkManager[1519]: <info> [1581222295.2673] device (ppp1399): interface index 7683 renamed iface from 'ppp1399' to 'pppoe1436'
Feb 09 09:54:55 hbbras00 NetworkManager[1519]: <info> [1581222295.2838] device (pppoe1436): state change: unmanaged -> unavailable (reason 'connection-assumed', sys-iface-state: 'external')
Feb 09 09:54:55 hbbras00 NetworkManager[1519]: <info> [1581222295.2854] device (pppoe1436): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'external')
Feb 09 09:57:56 hbbras00 NetworkManager[1519]: <info> [1581222476.3800] device (pppoe1436): state change: disconnected -> unmanaged (reason 'connection-assumed', sys-iface-state: 'external')
Feb 09 09:57:56 hbbras00 kernel: ppp1399: renamed from pppoe1436
Feb 09 09:57:56 hbbras00 NetworkManager[1519]: <info> [1581222476.8907] device (pppoe1436): interface index 7683 renamed iface from 'pppoe1436' to 'ppp1399'
Feb 09 09:58:04 hbbras00 kernel: pppoe1436: renamed from ppp1399
Feb 09 09:58:04 hbbras00 NetworkManager[1519]: <info> [1581222484.7752] device (ppp1399): interface index 7712 renamed iface from 'ppp1399' to 'pppoe1436'
Feb 09 09:58:04 hbbras00 NetworkManager[1519]: <info> [1581222484.7760] device (pppoe1436): state change: unmanaged -> unavailable (reason 'connection-assumed', sys-iface-state: 'external')
Feb 09 09:58:04 hbbras00 NetworkManager[1519]: <info> [1581222484.7782] device (pppoe1436): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'external')
Feb 09 10:03:04 hbbras00 kernel: ppp1399: renamed from pppoe1436
Feb 09 10:03:04 hbbras00 NetworkManager[1519]: <info> [1581222784.9151] device (pppoe1436): interface index 7712 renamed iface from 'pppoe1436' to 'ppp1399'
Feb 09 10:03:20 hbbras00 kernel: pppoe1436: renamed from ppp1149
Feb 09 10:03:20 hbbras00 NetworkManager[1519]: <info> [1581222800.6875] device (ppp1149): interface index 7762 renamed iface from 'ppp1149' to 'pppoe1436'
Feb 09 10:03:20 hbbras00 NetworkManager[1519]: <info> [1581222800.6879] device (pppoe1436): state change: unmanaged -> unavailable (reason 'connection-assumed', sys-iface-state: 'external')
Feb 09 10:03:20 hbbras00 NetworkManager[1519]: <info> [1581222800.6898] device (pppoe1436): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'external')
Feb 09 10:09:16 hbbras00 NetworkManager[1519]: <info> [1581223156.2918] device (pppoe1436): state change: disconnected -> unmanaged (reason 'connection-assumed', sys-iface-state: 'external')
Feb 09 10:09:16 hbbras00 kernel: ppp1149: renamed from pppoe1436
Feb 09 10:09:16 hbbras00 NetworkManager[1519]: <info> [1581223156.3371] device (pppoe1436): interface index 7762 renamed iface from 'pppoe1436' to 'ppp1149'
Feb 09 10:09:32 hbbras00 kernel: pppoe1436: renamed from ppp722
Feb 09 10:09:32 hbbras00 NetworkManager[1519]: <info> [1581223172.6024] device (ppp722): interface index 7819 renamed iface from 'ppp722' to 'pppoe1436'
Feb 09 10:09:32 hbbras00 NetworkManager[1519]: <info> [1581223172.6035] device (pppoe1436): state change: unmanaged -> unavailable (reason 'connection-assumed', sys-iface-state: 'external')
Feb 09 10:09:32 hbbras00 NetworkManager[1519]: <info> [1581223172.6075] device (pppoe1436): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'external')
Feb 09 10:14:31 hbbras00 kernel: ppp722: renamed from pppoe1436
Feb 09 10:14:31 hbbras00 NetworkManager[1519]: <info> [1581223471.8682] device (pppoe1436): interface index 7819 renamed iface from 'pppoe1436' to 'ppp722'
---------------------------------
currently running 1400 users with peak load of 2gbps
adding new vlans are not working will post more asap
thanks

dimka88
Posts: 624
Joined: 13 Oct 2014, 05:51
Contact:

Re: pppoe interfaces without ip address

Post by dimka88 » 09 Feb 2020, 13:30

Hi, after adding new vlans, you need also add this from accel-cmd CLI for pppoe, e.g.

Code: Select all

accel-cmd pppoe interface add eth1.300
About first issue, it really can related with NetworkManager, I need accel-ppp logs when this client connecting.

hashbang
Posts: 29
Joined: 12 Jul 2015, 10:28

Re: pppoe interfaces without ip address

Post by hashbang » 10 Feb 2020, 10:40

hi,
thanks
It seems to be problem with network manager. I disabled the networkmanager on saturday. What else I did :
1) A duplicate /24 address in ip pool (for next pool) was found
2) NetworkManager disabled
3) Kernel changed to 4.4 from 5.5 (as i wanted to compile latest intel drivers).
Since then everything seems stable.
1900 uses online
2.75gbps load
"Will add SOLVED later on asa i find all ok"
--------------------------------------------------
one more simple question
does accel-cmd reload works on changing ip-pool (adding more pools) ?
thanks again

dimka88
Posts: 624
Joined: 13 Oct 2014, 05:51
Contact:

Re: pppoe interfaces without ip address

Post by dimka88 » 10 Feb 2020, 15:58

accel-pppd not change ip-pools by reload.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests